Support for iOS 11 and macOS High Sierra (10.13) on Staff Wifi & Wired Network

Apple released iOS 11 for iPhone, iPad and iPod touch on Tuesday, 19th September and macOS Sierra (10.13) for Apple laptops and desktops on 25th September.

iOS 11

Our testing of iOS 11 for iPhone, iPad and iPod Touch is complete and a new version of the TCD Wifi app has been released on the iTunes App Store. This testing indicates that iOS 11.1 or later is required if registering these devices for the Staff Wi-Fi service. Students have been able to connect to TCDconnect with this version of iOS since 24th October.

macOS HighSierra

IT Services has completed testing of macOS High Sierra (10.13) for Apple laptops and desktops regarding its compatibility with the Trinity data network and IT systems.  We are pleased to announce it is now supported for use on the wired network in Trinity offices and labs and on the Staff Wi-Fi service. Support for macOS HighSierra on the student TCDconnect service was provided from 24th October. Further details of supported macOS software is available on our support statement page.

From 2nd July 2018 removal of support for computers with macOS 10.8 (Mountain Lion) & 10.9 (Mavericks)

Apple has ended support for macOS 10.8 & 10.9. This means that they are no longer providing software security updates for these operating systems and continuing to run these unsupported operating systems represents a security risk to the Trinity data network and to your own data. We will not be removing devices running these older operating systems from the Staff wifi & wired network, however, if your computer is running one of the older versions then we strongly encourage you to take action well in advance of 2nd July 2018 by upgrading your operating system to ensure you continue to receive full support from us. Information on how to upgrade, for free, to a more recent version of macOS can be found on the Apple website at www.apple.com/osx/how-to-upgrade

In advance of our end-of-support date, we will not accept any new requests to connect devices running macOS 10.8 or 10.9 to the network after 1st May 2018.

IT Services